北斗 发表于 2009-8-19 22:11:28

【郁闷】PXE模式启动后,PE中的NF2网卡见鬼了【已解决】【附0PE多部署详案】

测试用的PXE PE:

1、水大叔的911 W版

2、dvd008的骨头0818版

3、很久前逍遥浪子的20070325版
===================================

客户机:NF2主板的主机

===================================

用于NF2集成网卡的PE驱动:

前两天刚刚修正的NF2网卡驱动包,此驱动包在水大叔的888C版PE下可成功驱动网卡,访问互联网和局域网。

===================================

服务器:另外一台实机

===================================
DHCP TFTP环境:

在服务器上自己架设的haneWIN DHCP Server


===================================
故障现象:

1、如果把NF2主板的网卡屏蔽掉(其实不屏蔽掉也可以),单独插8139、82559桌面版和服务器版、530TX。以DHCP+TFTP启动上述3个PXE PE,启动网络正常,设备管理器中网卡驱动正常,Penetcfg中指定IP和网关、DNS后,访问互联网和局域网都没问题,就如在普通的PE中一样。

2、如果只用NF2主板的网卡,以DHCP+TFTP启动上述3个PXE PE,启动网络正常,驱动网卡在设备管理器中正常(dvd008的PE中没有设备管理器),在Penetcfg中指定IP和网关、DNS后,打开浏览器无法访问互联网,局域网的驱动器也不能映射。
===================================

已排除的因素:

1、DHCP TFTP环境影响,后期测试已经在引导完PXE PE后,关闭DHCP和TFTP,再开启PE的网络支持,但这样PXE PE还是不能访问网络。

2、驱动的问题,小马、dvd008、pseudo的能驱动NF2网卡的驱动都试过了,问题依旧。

===================================
问题的原因:

会是PE母体的问题吗,比如缺少DLL或者其它什么文件?还是驱动又不对头了??还是有其它原因,希望大家帮忙看一下,各抒己见,在此先谢谢诸位!

这PE干嘛老是和我的NF2网卡过不去啊

=====================================================================

NF2的PXE启动问题已解决,多谢pseudo兄弟,详见39楼pseudo的解决方法。

另:关于0PE的多方式部署详案,请看本贴的46楼,pseudo兄弟也做了详细的说明,原来0PE也是可以这样用的,非常感谢pseudo和各位兄弟~

[ 本帖最后由 北斗 于 2009-8-22 15:53 编辑 ]

dvd008 发表于 2009-8-20 09:51:07

如果两台机器测试,
nf2做服务器,客户机启动后,nf2的机器先关机,然后重新启动,看看nf2的上网正常不?

如果是虚拟机和本机的测试,我就没办法了

北斗 发表于 2009-8-20 10:27:44

原帖由 dvd008 于 2009-8-20 09:51 发表 http://bbs.wuyou.net/images/common/back.gif
如果两台机器测试,
nf2做服务器,客户机启动后,nf2的机器先关机,然后重新启动,看看nf2的上网正常不?

如果是虚拟机和本机的测试,我就没办法了

谢谢,按照上面的方法测试,还是不行。

我所有的测试都是实机测试,没有用到虚拟机。

dvd008 发表于 2009-8-20 10:48:17

没理由啊 !

nf2的机器重新启动,已经和客户机没有关系了,单独上网是不该有问题的,你前面已经测试过。
我这里说的不是关闭tftp服务器。

客户机启动了,拔掉网线,完全脱离nf2的机器,nf2重新启动,相当于正常启动,应该可以上网,
连接客户机,也应该能连上

另:骨头的 设备管理器,在mmc里面,启动mmc就可以了

12050202 发表于 2009-8-20 10:49:03

指定IP和网关、DNS
==========

我试水W版.从不需要设置的.都是"自动获取".

按他介绍的步骤办.很正常.

既然换网卡就正常了.而内置网卡不正常.可排除PE的问题.

如怀疑PE问题.水老C版.合盘后.也能网启.C版内DLL超多.

北斗 发表于 2009-8-20 11:25:55

原帖由 dvd008 于 2009-8-20 10:48 发表 http://bbs.wuyou.net/images/common/back.gif
没理由啊 !

nf2的机器重新启动,已经和客户机没有关系了,单独上网是不该有问题的,你前面已经测试过。
我这里说的不是关闭tftp服务器。

客户机启动了,拔掉网线,完全脱离nf2的机器,nf2重新启动,相当 ...

是因为我没说明白,还是理解方面有歧义了,我们讨论的NF2机是做为客户机启动的,不是服务器。(不过已按你2楼的方法测试过)

事实上,是另外一台机做服务器并开启了DHCP和TFTP,NF2机做为客户机,去连接服务器。

另外,为了排除NF2机的网卡和服务器的网卡冲突,已经换过另外的机做服务器了,故障依旧。

我这样说,应该明白了吧??

[ 本帖最后由 北斗 于 2009-8-20 11:33 编辑 ]

北斗 发表于 2009-8-20 11:28:16

原帖由 12050202 于 2009-8-20 10:49 发表 http://bbs.wuyou.net/images/common/back.gif
指定IP和网关、DNS
==========

我试水W版.从不需要设置的.都是"自动获取".

按他介绍的步骤办.很正常.

既然换网卡就正常了.而内置网卡不正常.可排除PE的问题.

如怀疑PE问题.水老C版.合盘后.也能网启 ...

多谢~~

应该和手动或自动指定IP网关DNS没有关系,因为NF2插独立网卡的时候,PXE启动后,手动指定IP网关DNS,上网都正常。此前也开启过内网DHCP服务,NF2测试依然不能上网。

水大叔的C版的W版都有试过,把里面的网卡驱动都已更换为在888C下工作正常的NV驱动,但还是不行。

水大叔也提醒过我,说C版里的DLL比较多,所以特别测试过。

[ 本帖最后由 北斗 于 2009-8-20 11:36 编辑 ]

66369 发表于 2009-8-20 11:40:22

客户机启动后.先关闭服务器机器.

而后再加载网络支持.看能不能上网.从而确认驱动是否正常.

dvd008 发表于 2009-8-20 11:44:18

这回明白了
既然nf客户机,单独启动(非网络启动)是正常的,也能上网连接服务器,
只是网络启动后不能

那请截图: 单独启动时,资源那里的 就是 IRQ那地方
                网络启动时的 也要

试一试,卸掉网卡,然后重新安装一次

北斗 发表于 2009-8-20 11:45:02

原帖由 66369 于 2009-8-20 11:40 发表 http://bbs.wuyou.net/images/common/back.gif
客户机启动后.先关闭服务器机器.

而后再加载网络支持.看能不能上网.从而确认驱动是否正常.

这个方案先前已做过测试,关闭了服务器,而客户机NF2还是不能访问互联网和局域网。
页: [1] 2 3 4 5 6
查看完整版本: 【郁闷】PXE模式启动后,PE中的NF2网卡见鬼了【已解决】【附0PE多部署详案】