szfhx 发表于 2012-12-26 12:37:36

虚拟机VMWare“提示:软件虚拟化与此平台上的长模式不兼容”的解决方案

虚拟机VMWare的使用,不少童鞋反映,在使用Windows7 64位操作系统时,无法运行VMWare或MS Virtual server等软件虚拟操作系统。提示为“提示:软件虚拟化与此平台上的长模式不兼容. 禁用长模式. 没有长模式支持, 虚拟机将不能运行 64 位程序. ”产生这个错误的主要原因是现在平常用的VMWare等软件本身都是基于32位的,如果要在其上运行64位虚拟机,需要把虚拟化打开!而Windows7 64位操作系统在默认情况下是关闭的!


一、打开64位CPU的VT选项,开启虚拟化。这是永久性的解决方案,但受到CPU型号的限制,部分CPU并不支持开启虚拟化。
1、需要重启电脑后登录BIOS设置界面,进入“Configuration”或“Advanced”菜单,找到 “Intel(R) Virtual Technology”选项,将其值改为“Enabled”,保存退出后登录系统。

[ 本帖最后由 szfhx 于 2012-12-28 08:48 编辑 ]

szfhx 发表于 2012-12-26 12:38:40

二、部分CPU不支持开启虚拟化的,可以通过修改VMWare软件设定,临时性解决不兼容问题。
但新建虚拟机后,需要再次进行以下设置。
1、对虚拟机相对应的.vmx文件进行编辑修改。用记事本打开.vmx文件,找到:vmci0.present=“TRUE”将TRUE改为FALSE或者直接将这行删掉。保存此虚拟机的.vmx文件(可能先要关闭Vm,然后才能保存,再打开VM)。重新运行虚拟机。OK。(注意:刚刚安装好VMware Workstation以后是找不到这个文件的,当你在VMware Workstation中建立了一个虚拟机以后,这个文件才会出现。)

vmci0.present=“TRUE”
改为

vmci0.present = "FALSE"

2、[这一步非必要操作]在vm软件界面上,编辑虚拟机设置。在虚拟机设置->选项->客户机隔离->VM通信接口(VMCI)把启用VMCI的钩去掉。点击确定保存。重新运行虚拟机。OK。

[ 本帖最后由 szfhx 于 2012-12-28 08:51 编辑 ]

2012szbtt 发表于 2012-12-27 15:32:35

感谢 最近装x64系统了
页: [1]
查看完整版本: 虚拟机VMWare“提示:软件虚拟化与此平台上的长模式不兼容”的解决方案