xuming98 发表于 2019-3-8 14:09:08

pe装入硬盘无法启动,求高手指导

本帖最后由 xuming98 于 2019-3-8 14:17 编辑

参照坛内大侠贴-http://bbs.wuyou.net/forum.php?mod=viewthread&tid=355724&extra=page%3D1,系统为xp可正常引导,pe为坛内找的7pe装入最后一区并设为主分区,8pe都是x86的,换了好几个,都是不能引导,不知道毛病在哪?
主板是华硕945的,cpue8500,内存2g,硬盘机械。

苏州本是 发表于 2019-3-8 15:06:11

可以参考此贴:将网上的Win8.1 RAMOS 还原成硬盘操作系统
http://bbs.wuyou.net/forum.php?mod=viewthread&tid=337418

步骤中特别要注意:
2、BCD编辑部分的最后一张图,
打开BOOTICE,找到安装盘\boot\bcd,按图修改如下——

尤其是图中的1、4、5。

3、修正分区号(操作注册表)
\DosDevices\?:

xuming98 发表于 2019-3-8 15:44:56

苏州本是 发表于 2019-3-8 15:06
可以参考此贴:将网上的Win8.1 RAMOS 还原成硬盘操作系统
http://bbs.wuyou.net/forum.php?mod=viewthread ...

感谢回复!这是另一种思路,不是我想要的

永远的大象 发表于 2019-3-8 18:12:55

当年还在用联想的天逸200的时候玩过这个方法:
说下几个地方需要注意下:
首先,放PE的分区引导记录(PBR)改为PE所对应的启动方式,你的是 Windows NT 6.x,你没选错。
其次,你的主引导用的 1JF9 by Luyanan ,要区分好版本,你的也看不出来什么问题
第三,PE的引导文件,你所用的PE我不能确认引导文件是否正常,建议只提取出WIM文件,改名为boot.wim,从原版的系统镜像内提取三个文件:bootmgr、boot目录内的BCD和BOOT.SDI
然后,bootmgr 放在PE分区根目录,建一个文件夹boot,文件夹内放BCD,BOOT.SDI,boot.wim。
文件结构如下:


    bcd
    boot.sdi
    boot.wim
bootmgr

由于你没有提供失败的截图,也无法判断启动失败的原因,但是有几个地方需要注意:
BCD文件内记录的SDI文件,要准确指向boot.sdi
BCD文件内的引导记录,要标注了是启动PE
WIM文件如果解包重新打包,要记得加上可启动标识,不然启动不了

xnj19 发表于 2019-3-8 18:31:54

本帖最后由 xnj19 于 2019-3-8 18:36 编辑

不是所有PE放在硬盘都能启动,本人用微PE放在硬盘可启动。方法是:将微PE的ISO文件解压到硬盘分区,将里面的WIM文件替换成自己喜欢PE的WIM,改文件名和微PE一样。
打开BOOTICE,按下图建立PE的引导,注意其中“SDI文件”栏右边的 【H:] 里面的分区设置要和外面启动磁盘和启动分区一致。

hilsonma 发表于 2019-3-8 23:00:44

我没有用过1JF9引导,我觉得应该是1JF9引导的设定问题
象你这样的部署,我会用Grub4Dos引导,默认引导XP分区的ntldr进入xp系统,按上下箭头选择引导PE分区的bootmgr进入pe
pe的相关文件bootmgr、bcd、boot.sdi、boot.wim必须是全套从同一个镜像上提取的并保持相同的文件夹结构,否则就要做相应的设置。

icons 发表于 2019-3-9 09:53:31

本帖最后由 icons 于 2019-3-9 09:55 编辑

用逻辑分区作为救护分区,在启动顺序选择救护分区。

lbw2007 发表于 2019-3-9 10:12:00

不建议这么用,最安全的还是用grldr直接仿真ISO。路过帮顶

xuming98 发表于 2019-3-9 11:14:44

本帖最后由 xuming98 于 2019-3-9 11:22 编辑

感谢以上各位回复!
今天在另一台华硕b75主板测试,设置不变,win7PE和8PE均能正常加载。所以判定和主板及芯片有关系!!!
945主板支持安装win7,为什么不支持7PE?难以理解,难道和BIOS设置有关系?回头找个03PE试一试
希望坛内高手指教,老主板有什么玄机?U盘pe不论03PE.07PE.8PEx86均能启动

vaf 发表于 2019-3-9 11:56:56

hilsonma 发表于 2019-3-8 23:00
我没有用过1JF9引导,我觉得应该是1JF9引导的设定问题
象你这样的部署,我会用Grub4Dos引导,默认引导XP分 ...

支持,用 NT5 引导更简单。
页: [1] 2 3
查看完整版本: pe装入硬盘无法启动,求高手指导