zhaohj 发表于 2007-1-23 00:13:28

我的也可以,YONSM1.14版+FBWF

wchf2 发表于 2007-1-23 00:19:15

关于快速启动栏没有出来的现象,我来说两句,大概有30%~50%的几率会在我的机器上出现,我用的是“(1月9日)利用XCMD和INFCACHE全自动化安装驱动,跟XP一样的老九元旦多媒体版”,本以为acoa大侠下版会解决,现在就麻烦您先给瞧瞧喽。

lxl1638 发表于 2007-1-23 01:23:46

快速启动栏位于深层多级目录,可能XCMD没有建立这个深层多级目录,本人刚试,若在IMG中事先建立这个目录,快速启动栏就出来了。

原因是不少PE的IMG内没有事先建立这个深层多级目录。

是否会建立这样的深层多级目录,还需原作者来解释,本人也在找代码。若是Delphi,一个4行简单的递归就搞定,但刚学VC,函数都没找到,更不要说用法。

lxl1638 发表于 2007-1-23 01:31:18

原帖由 zhaohj 于 2007-1-23 12:13 AM 发表
我的也可以,YONSM1.14版+FBWF

你的IMG是不是已经存在那个目录了?

strongchen 发表于 2007-1-23 01:58:20

老九加一个获取系统可用内存的命令阿,在启动过程中可用判断很多事情。虽然现在用 systeminfo.exe 也可以,但这个exe占47K空间,太大了。

triquan 发表于 2007-1-23 04:37:38

原帖由 lxl1638 于 2007-1-23 01:31 AM 发表


你的IMG是不是已经存在那个目录了?
我用的也是(1月9日)版的,可以出来快速启动,好像和命令执行顺序有关,我的执行顺序是:设置fbwf--注册组件--设定系统--创建内部快捷方式--加载外部配置(安装外部软件--创建外部快捷方式--外部文档关联--设置虚拟内存和加载壁纸)--载入桌面(先kill xx,再logo,最后才EXEC $EXPELORER)--file清理垃圾

xdg3669 发表于 2007-1-23 07:51:28

原帖由 lxl1638 于 2007-1-22 11:23 PM 发表


你的IMG是那个版本的?

我用的是你的元旦YY版。没有事先建立文件夹。

[ 本帖最后由 xdg3669 于 2007-1-23 07:53 AM 编辑 ]

acoa 发表于 2007-1-23 08:10:04

原帖由 wchf2 于 2007-1-23 12:19 AM 发表
关于快速启动栏没有出来的现象,我来说两句,大概有30%~50%的几率会在我的机器上出现,我用的是“(1月9日)利用XCMD和INFCACHE全自动化安装驱动,跟XP一样的老九元旦多媒体版”,本以为acoa大侠下版会解决,现在 ...
不知你是否改了什么东东了,我在所有的机器每次都可以出来的。从没有过不出来的现象。

emca 发表于 2007-1-23 08:28:16

我似乎找到原因:
每种命令开始前,必须有一个空行,或者 //,比如 Link 类型的命令开始前就必须有,其他依此类推。
另外,如果菜单项目中,存在相同路径的条目(比如我们可能会把某些具有多种功能特性的程序同时放到两个菜单下以方便查找),则肯定会重现不能出现菜单的故障。
其实,快速启动栏和菜单项不出来时,系统仍然是创建了它们,只不过路径不正确,它被创建到 X\I386\ 这个目录下,而且是以 %QuickLaunch% 这样的原始变量名存在的目录!也就是说,出错后,系统环境变量丢失。——这才是问题原因的根本,可能是程序代码中处理环境变量有欠缺,当创建菜单的函数遇到异常时(包括开始标志、路径等是否重复等),变量开始失效。从而导致上述故障。

zhaohj 发表于 2007-1-23 08:28:33

原帖由 lxl1638 于 2007-1-23 01:31 AM 发表


你的IMG是不是已经存在那个目录了?

只建了个user目录,user目录是空的
页: 1 2 3 4 5 6 7 [8] 9 10 11 12 13 14 15 16 17
查看完整版本: [PECMD X86 & X64 V4.0.2011.0501版] WinPE命令解释程序 & WinPE登录命令。