无忧启动论坛

 找回密码
 注册
搜索
WEPE笔记本电脑手机维修小包 IT发烧友的必备工具最纯净的「微PE装机优盘」UEPON大师作品卡瑞飞系统和装机二合一超级U盘
广告位招租系统gho:最纯净好用系统下载站广告联系 QQ:184822951 微信:wuyouceo
楼主: wuhenxpe

[原创] 诺达佳U盘维护系统v5.5.1发布(UD+EFI三分区)20170623更新

  [复制链接]
发表于 2017-6-10 14:03:34 | 显示全部楼层
本帖最后由 wintoflash 于 2017-6-10 14:06 编辑
测试没有成功,卡在启动画面

你先用grub2启动一下你机器上的Windows系统试试。
bootmgfw.efi那个。
  1. menuentry "查找并启动Windows系统(EFI)" --class windows{
  2.         search --set -f /efi/microsoft/boot/bootmgfw.efi
  3.         chainloader /efi/microsoft/boot/bootmgfw.efi
  4. }
复制代码

点评

正确的参数 如下 需要增加一行 terminal_output console menuentry "启动 Windows 10 PE " { search --file ($root)/efi/win10/boot/bootmgfw.efi --set=root terminal_output console chainloader  详情 回复 发表于 2017-6-17 14:44
同一个ISO镜像,其它 1个U盘使用utraiso写入出现下图报错,什么原因啊 。 [attachimg]347643[/attachimg]  详情 回复 发表于 2017-6-10 18:00
用 QEMU测试启动不了 ,真正没有测试,我电脑是win7 系统  详情 回复 发表于 2017-6-10 14:22
回复

使用道具 举报

 楼主| 发表于 2017-6-10 14:22:34 | 显示全部楼层
wintoflash 发表于 2017-6-10 14:03
你先用grub2启动一下你机器上的Windows系统试试。
bootmgfw.efi那个。

用 QEMU测试启动不了  ,真正没有测试,我电脑是win7 系统

点评

同一个ISO镜像,其它 1个U盘使用utraiso写入出现下图报错,什么原因啊 。 [attachimg]347643[/attachimg]  详情 回复 发表于 2017-6-10 17:59
谢谢 ,本机实测已解决 , QEMU 有BUG啊 。  详情 回复 发表于 2017-6-10 15:05
各种虚拟机的EFI都有bug, 一定要实机测试  发表于 2017-6-10 14:38
回复

使用道具 举报

 楼主| 发表于 2017-6-10 15:05:10 | 显示全部楼层
wuhenxpe 发表于 2017-6-10 14:22
用 QEMU测试启动不了  ,真正没有测试,我电脑是win7 系统

谢谢 ,本机实测已解决 , QEMU 有BUG啊 。
回复

使用道具 举报

 楼主| 发表于 2017-6-10 17:59:59 | 显示全部楼层
wuhenxpe 发表于 2017-6-10 14:22
用 QEMU测试启动不了  ,真正没有测试,我电脑是win7 系统


同一个ISO镜像,其它 1个U盘使用utraiso写入出现下图报错,什么原因啊 。

1.png
回复

使用道具 举报

 楼主| 发表于 2017-6-10 18:00:37 | 显示全部楼层
wintoflash 发表于 2017-6-10 14:03
你先用grub2启动一下你机器上的Windows系统试试。
bootmgfw.efi那个。
wuhenxpe 发表于 2017-6-10 14:22
用 QEMU测试启动不了  ,真正没有测试,我电脑是win7 系统


同一个ISO镜像,其它 1个U盘使用utraiso写入出现下图报错,什么原因啊 。

点评

出现这个的原因是grldr没有找到menu.lst。具体为啥找不到,我也不清楚。到grub4dos区发帖问一下吧。  详情 回复 发表于 2017-6-10 18:14
回复

使用道具 举报

发表于 2017-6-10 18:14:24 | 显示全部楼层
wuhenxpe 发表于 2017-6-10 18:00
同一个ISO镜像,其它 1个U盘使用utraiso写入出现下图报错,什么原因啊 。

出现这个的原因是grldr没有找到menu.lst。具体为啥找不到,我也不清楚。到grub4dos区发帖问一下吧。
回复

使用道具 举报

发表于 2017-6-10 19:45:52 | 显示全部楼层
非常感谢楼主的分享!谢谢!
回复

使用道具 举报

 楼主| 发表于 2017-6-17 14:44:20 | 显示全部楼层
本帖最后由 wuhenxpe 于 2017-6-17 14:47 编辑
wintoflash 发表于 2017-6-10 14:03
你先用grub2启动一下你机器上的Windows系统试试。
bootmgfw.efi那个。


正确的参数 如下 需要增加一行  terminal_output console

menuentry "启动 Windows 10 PE " {
      search --file ($root)/efi/win10/boot/bootmgfw.efi --set=root
        terminal_output console
        chainloader ($root)/efi/win10/bootmgfw.efi

我是运行时,实际上有一  按 任意键 默认是等待3秒 ,这个时间如何去掉 ?

点评

不需要terminal_output console. 我也没有见过什么等待三秒的东西  详情 回复 发表于 2017-6-17 15:09
回复

使用道具 举报

发表于 2017-6-17 15:09:32 | 显示全部楼层
wuhenxpe 发表于 2017-6-17 14:44
正确的参数 如下 需要增加一行  terminal_output console

menuentry "启动 Windows 10 PE " {

不需要terminal_output console.
我也没有见过什么等待三秒的东西
回复

使用道具 举报

发表于 2017-6-17 15:11:12 | 显示全部楼层
search --file ($root)/efi/win10/boot/bootmgfw.efi --set=root这句也是错误的.

点评

terminal_output console 不加这句 , ISO写入方式 win 8 \WIN10引导报错 。这句话意思就是在 uefi shell下运行bootmgfw.efi 吧  详情 回复 发表于 2017-6-17 15:57
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|捐助支持|无忧启动 ( 闽ICP备05002490号-1 )

闽公网安备 35020302032614号

GMT+8, 2019-8-26 06:21

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表