无忧启动论坛

 找回密码
 注册
搜索
最纯净的「微PE装机优盘」UEPON大师作品系统gho:最纯净好用系统下载站数据恢复、数据保护、视频编辑
Win To Go 极致利器(IXUNCIS固态U盘)无忧启动网成立20周年!广告联系 QQ:184822951 微信:wuyouceo
12
返回列表 发新帖
楼主: yyychn

请教tiny pxe server的启动问题(跨VLAN反复循环)

[复制链接]
发表于 2020-11-22 00:56:58 | 显示全部楼层
cfjy8 发表于 2020-11-21 12:43
大佬,还在吗,如果你已经解决了,能否帮小弟说一说方法,如果可行,到时候我给学费可以吗

請詳細點說明你的網絡

建議你使用ipxe,編譯為內置腳本。放在最上游的dhcp pool,當任何vlan內機器需要pxe啟動時由dhcp直接分發。
(vlan情景proxydhcp像不是太合適了)

腳本使用的協議也是要較講究,因為要跨vlan,如tftp就不合適了;簡單又快直接http/ftp吧。

那http/ftp伺服器放在最上游,跟dhcp pool一起就最簡單
回复

使用道具 举报

发表于 2020-11-25 23:15:42 | 显示全部楼层
cfjy8 发表于 2020-11-21 12:43
大佬,还在吗,如果你已经解决了,能否帮小弟说一说方法,如果可行,到时候我给学费可以吗

1、华为S5730交换机作为三层交换机
2、划分3个vlan,vlan50(192.168.0.0-192.168.7.254/21) vlan70(192.168.8.0-192.168.15.254/21) vlan100(192.168.16.0-192.168.23.254/21)
3、tiny PXE服务器部署在VLAN50的192.168.0.222这个服务器上,服务器的端口直接连接在核心交换机的其中一个端口中

   需求,希望在3个网段均能正常使用tiny PXE引导PE,避免使用U盘,通过PE登录后使用里面的网络工具连接内网段共享文件夹进行安装系统。
   目前在交换机中已经undo dhcp snooping enable,vlan50这个vlan下面的汇聚层下(包含接入层下)所连接的所有PC均能正常通过PXE网络启动了,现在希望实现在vlan70和vlan100下面也能实现PXE网络启动。
回复

使用道具 举报

发表于 2020-11-25 23:25:27 | 显示全部楼层
由于我没有权限发图和附件,连网址都无法发布,所以能否请你加我的QQ帮我远程处理一下。谢谢
回复

使用道具 举报

发表于 2020-11-27 19:57:44 | 显示全部楼层
hkkitlee 发表于 2020-11-22 00:56
請詳細點說明你的網絡

建議你使用ipxe,編譯為內置腳本。放在最上游的dhcp pool,當任何vlan內機器需 ...

1、华为S5730交换机作为三层交换机
2、划分3个vlan,vlan50(192.168.0.0-192.168.7.254/21) vlan70(192.168.8.0-192.168.15.254/21) vlan100(192.168.16.0-192.168.23.254/21)
3、tiny PXE服务器部署在VLAN50的192.168.0.222这个服务器上,服务器的端口直接连接在核心交换机的其中一个端口中

   需求,希望在3个网段均能正常使用tiny PXE引导PE,避免使用U盘,通过PE登录后使用里面的网络工具连接内网段共享文件夹进行安装系统。
   目前在交换机中已经undo dhcp snooping enable,vlan50这个vlan下面的汇聚层下(包含接入层下)所连接的所有PC均能正常通过PXE网络启动了,现在希望实现在vlan70和vlan100下面也能实现PXE网络启动。

点评

那bootserver,http/ftp伺服器放在最上游,跟dhcp pool一起  详情 回复 发表于 2020-12-1 12:48
回复

使用道具 举报

发表于 2020-11-30 20:24:54 | 显示全部楼层
江南一根葱 发表于 2017-10-15 14:32
跨vlan用ipxe需要指定服务器地址,你自己去生成一个吧,方法见论坛同类问题
https://rom-o-matic.eu/

...

请问江南大佬,具体怎么生成或者说怎么编译,可否授予一下方法,我公司现在的网络情况如下:如果帮我解决了,请你吃火锅

1、华为S5730交换机作为三层交换机
2、划分3个vlan,vlan50(192.168.0.0-192.168.7.254/21) vlan70(192.168.8.0-192.168.15.254/21) vlan100(192.168.16.0-192.168.23.254/21)
3、tiny PXE服务器部署在VLAN50的192.168.0.222这个服务器上,服务器的端口直接连接在核心交换机的其中一个端口中

   需求,希望在3个网段均能正常使用tiny PXE引导PE,避免使用U盘,通过PE登录后使用里面的网络工具连接内网段共享文件夹进行安装系统。
   目前在交换机中已经undo dhcp snooping enable,vlan50这个vlan下面的汇聚层下(包含接入层下)所连接的所有PC均能正常通过PXE网络启动了,现在希望实现在vlan70和vlan100下面也能实现PXE网络启动。

点评

最简单粗暴的方法是每个vlan和服务器连接一个网口,每个网卡都监听,代理dhcp网启 有技术含量的方法是配置交换机dhcp地址池,钦定一个固定的next-server,也就是tftp服务器地址  详情 回复 发表于 2020-12-7 10:09
回复

使用道具 举报

发表于 2020-12-1 12:48:54 | 显示全部楼层
cfjy8 发表于 2020-11-27 19:57
1、华为S5730交换机作为三层交换机
2、划分3个vlan,vlan50(192.168.0.0-192.168.7.254/21) vlan70(1 ...

那bootserver,http/ftp伺服器放在最上游,跟dhcp pool一起
回复

使用道具 举报

发表于 2020-12-3 23:14:30 | 显示全部楼层
hkkitlee 发表于 2020-12-1 12:48
那bootserver,http/ftp伺服器放在最上游,跟dhcp pool一起

我还是不明白你的意思,我这样理解一下
是否要求我将DHCP由原来的DHCP接口模式undo掉?在全局下面配置DHCP?
具体我还是不太明白,交换机里面具体要怎么配置,还有tiny PXE里面又应该选择哪一项。。因为底子太薄,有劳师兄,有空的话,麻烦帮忙ensp里面配个命令粘贴一下吧,感激不尽

点评

主要配置改動trunk把bootserver,http/ftp伺服器放在最上游。 具體命令的看你買的品牌說明書 如果你不是網管,真的要問清楚可不可以改動,錯誤改動會癱瘓網絡 如果你是的話應該明白我的意思  详情 回复 发表于 2020-12-6 23:00
回复

使用道具 举报

发表于 2020-12-6 23:00:26 | 显示全部楼层
cfjy8 发表于 2020-12-3 23:14
我还是不明白你的意思,我这样理解一下
是否要求我将DHCP由原来的DHCP接口模式undo掉?在全局下面配置DH ...

主要配置改動trunk把bootserver,http/ftp伺服器放在最上游。
具體命令的看你買的品牌說明書

如果你不是網管,真的要問清楚可不可以改動,錯誤改動會癱瘓網絡
如果你是的話應該明白我的意思
回复

使用道具 举报

发表于 2020-12-7 10:09:40 | 显示全部楼层
本帖最后由 江南一根葱 于 2020-12-7 10:10 编辑
cfjy8 发表于 2020-11-30 20:24
请问江南大佬,具体怎么生成或者说怎么编译,可否授予一下方法,我公司现在的网络情况如下:如果帮我解决 ...

最简单粗暴的方法是每个vlan和服务器连接一个网口,每个网卡都监听,代理dhcp网启(实际上可以单独弄个vlan接到服务器网口,再配置相应的trunk口)
有技术含量的方法是配置交换机dhcp地址池,钦定一个固定的next-server,也就是tftp服务器地址
回复

使用道具 举报

发表于 2020-12-11 00:18:53 | 显示全部楼层
本帖最后由 cfjy8 于 2020-12-16 20:49 编辑
hkkitlee 发表于 2020-12-1 12:48
那bootserver,http/ftp伺服器放在最上游,跟dhcp pool一起

[ttl-10F-hexin]dis cu
#
sysname ttl-10F-hexin
#
vlan batch 50 70 100 150 200
#
cluster enable
ntdp enable
ndp enable
#
dot1x enable
dot1x authentication-method eap
#
undo nap slave enable
#
drop illegal-mac alarm
#
dhcp enable
#
diffserv domain default
#
radius-server template test
radius-server shared-key cipher %NS[+B0ZNI]NZPO3JBXBHA!!
radius-server authentication 192.168.1.240 1812
radius-server accounting 192.168.1.240 1812
radius-server retransmit 2
undo radius-server user-name domain-included
#
drop-profile default
#
aaa
authentication-scheme default
authentication-scheme zytmm.com
  authentication-mode radius
authentication-scheme test
  authentication-mode radius
authorization-scheme default
accounting-scheme default
accounting-scheme zytmm.com
  accounting-mode radius
  accounting start-fail online
domain default
domain default_admin
domain zytmm.com
  authentication-scheme zytmm.com
  accounting-scheme zytmm.com
  radius-server  test
local-user admin password cipher ,J54RL(#H#)NZPO3JBXBHA!!
local-user admin privilege level 15
local-user admin service-type 8021x
#
interface Vlanif1
#
interface Vlanif50
ip address 192.168.1.1 255.255.248.0
dhcp select interface
dhcp server dns-list 192.168.0.200 61.139.2.69
#
interface Vlanif70
ip address 192.168.8.1 255.255.248.0
dhcp select interface
dhcp select relay
dhcp relay server-ip 192.168.7.247
#
interface Vlanif100
ip address 192.168.16.1 255.255.248.0
dhcp select interface
dhcp server dns-list 192.168.0.200 192.168.0.201
#
interface Vlanif150
ip address 192.168.30.1 255.255.255.0
#
interface MEth0/0/1
#
interface Eth-Trunk5
port link-type trunk
port trunk pvid vlan 50
port trunk allow-pass vlan 50 150
#
interface Eth-Trunk7
port link-type trunk
port trunk pvid vlan 70
port trunk allow-pass vlan 70 150
#
interface Eth-Trunk10
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100 150
#
interface Eth-Trunk11
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100 150
#
interface GigabitEthernet0/0/1
eth-trunk 5
#
interface GigabitEthernet0/0/2
eth-trunk 5
#
interface GigabitEthernet0/0/3
eth-trunk 5
#
interface GigabitEthernet0/0/4
eth-trunk 5
#
interface GigabitEthernet0/0/5
eth-trunk 7
#
interface GigabitEthernet0/0/6
eth-trunk 7
#
interface GigabitEthernet0/0/7
eth-trunk 7
#
interface GigabitEthernet0/0/8
eth-trunk 7
#
interface GigabitEthernet0/0/9
eth-trunk 10
#
interface GigabitEthernet0/0/10
eth-trunk 10
#
interface GigabitEthernet0/0/11
eth-trunk 10
#
interface GigabitEthernet0/0/12
eth-trunk 10
#
interface GigabitEthernet0/0/13
eth-trunk 11
#
interface GigabitEthernet0/0/14
eth-trunk 11
#
interface GigabitEthernet0/0/15
eth-trunk 11
#
interface GigabitEthernet0/0/16
eth-trunk 11
#
interface GigabitEthernet0/0/17
port link-type access
port default vlan 50
#
interface GigabitEthernet0/0/18
port link-type access
port default vlan 50
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
port link-type access
port default vlan 50
#
interface NULL0
#
user-interface con 0
user-interface vty 0 4
authentication-mode aaa
user privilege level 15
#
port-group 1
group-member GigabitEthernet0/0/1
group-member GigabitEthernet0/0/2
group-member GigabitEthernet0/0/3
group-member GigabitEthernet0/0/4
group-member GigabitEthernet0/0/5
group-member GigabitEthernet0/0/6
group-member GigabitEthernet0/0/7
group-member GigabitEthernet0/0/8
group-member GigabitEthernet0/0/9
group-member GigabitEthernet0/0/10
group-member GigabitEthernet0/0/11
group-member GigabitEthernet0/0/12
#
port-group 11
group-member GigabitEthernet0/0/13
group-member GigabitEthernet0/0/14
group-member GigabitEthernet0/0/15
group-member GigabitEthernet0/0/16
#
port-group eth5
group-member GigabitEthernet0/0/1
group-member GigabitEthernet0/0/2
group-member GigabitEthernet0/0/3
group-member GigabitEthernet0/0/4
#
port-group eth7
group-member GigabitEthernet0/0/5
group-member GigabitEthernet0/0/6
group-member GigabitEthernet0/0/7
group-member GigabitEthernet0/0/8
#
port-group eth10
group-member GigabitEthernet0/0/9
group-member GigabitEthernet0/0/10
group-member GigabitEthernet0/0/11
group-member GigabitEthernet0/0/12
#
port-group eth11
group-member GigabitEthernet0/0/13
group-member GigabitEthernet0/0/14
group-member GigabitEthernet0/0/15
group-member GigabitEthernet0/0/16
#
return
[ttl-10F-hexin]

点评

不要放在三層交換機中啊!!!將pxe相關的伺服器放在路由器dhcp的同層網絡(switch)中啊!!! 大約根據你的vlan設定,pxe 相關伺服器tcp/ip netmask 應調整至255.255.0.0。 我真的不知道可以再怎麼簡單的說清  详情 回复 发表于 2020-12-11 16:30
回复

使用道具 举报

发表于 2020-12-11 00:22:16 | 显示全部楼层
本帖最后由 cfjy8 于 2020-12-16 20:44 编辑
江南一根葱 发表于 2020-12-7 10:09
最简单粗暴的方法是每个vlan和服务器连接一个网口,每个网卡都监听,代理dhcp网启(实际上可以单独弄个vla ...

请帮忙分析一下,我现在的核心配置如下:应该怎么更改配置方案?多谢啦!

[ttl-10F-hexin]dis cu
#
sysname ttl-10F-hexin
#
vlan batch 50 70 100 150 200
#
cluster enable
ntdp enable
ndp enable
#
dot1x enable
dot1x authentication-method eap
#
undo nap slave enable
#
drop illegal-mac alarm
#
dhcp enable
#
diffserv domain default
#
radius-server template test
radius-server shared-key cipher %NS[+B0ZNI]NZPO3JBXBHA!!
radius-server authentication 192.168.1.240 1812
radius-server accounting 192.168.1.240 1812
radius-server retransmit 2
undo radius-server user-name domain-included
#
drop-profile default
#
aaa
authentication-scheme default
authentication-scheme zytmm.com
  authentication-mode radius
authentication-scheme test
  authentication-mode radius
authorization-scheme default
accounting-scheme default
accounting-scheme zytmm.com
  accounting-mode radius
  accounting start-fail online
domain default
domain default_admin
domain zytmm.com
  authentication-scheme zytmm.com
  accounting-scheme zytmm.com
  radius-server  test
local-user admin password cipher ,J54RL(#H#)NZPO3JBXBHA!!
local-user admin privilege level 15
local-user admin service-type 8021x
#
interface Vlanif1
#
interface Vlanif50
ip address 192.168.1.1 255.255.248.0
dhcp select interface
dhcp server dns-list 192.168.0.200 61.139.2.69
#
interface Vlanif70
ip address 192.168.8.1 255.255.248.0
dhcp select interface
dhcp select relay
dhcp relay server-ip 192.168.7.247
#
interface Vlanif100
ip address 192.168.16.1 255.255.248.0
dhcp select interface
dhcp server dns-list 192.168.0.200 192.168.0.201
#
interface Vlanif150
ip address 192.168.30.1 255.255.255.0
#
interface MEth0/0/1
#
interface Eth-Trunk5
port link-type trunk
port trunk pvid vlan 50
port trunk allow-pass vlan 50 150
#
interface Eth-Trunk7
port link-type trunk
port trunk pvid vlan 70
port trunk allow-pass vlan 70 150
#
interface Eth-Trunk10
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100 150
#
interface Eth-Trunk11
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100 150
#
interface GigabitEthernet0/0/1
eth-trunk 5
#
interface GigabitEthernet0/0/2
eth-trunk 5
#
interface GigabitEthernet0/0/3
eth-trunk 5
#
interface GigabitEthernet0/0/4
eth-trunk 5
#
interface GigabitEthernet0/0/5
eth-trunk 7
#
interface GigabitEthernet0/0/6
eth-trunk 7
#
interface GigabitEthernet0/0/7
eth-trunk 7
#
interface GigabitEthernet0/0/8
eth-trunk 7
#
interface GigabitEthernet0/0/9
eth-trunk 10
#
interface GigabitEthernet0/0/10
eth-trunk 10
#
interface GigabitEthernet0/0/11
eth-trunk 10
#
interface GigabitEthernet0/0/12
eth-trunk 10
#
interface GigabitEthernet0/0/13
eth-trunk 11
#
interface GigabitEthernet0/0/14
eth-trunk 11
#
interface GigabitEthernet0/0/15
eth-trunk 11
#
interface GigabitEthernet0/0/16
eth-trunk 11
#
interface GigabitEthernet0/0/17
port link-type access
port default vlan 50
#
interface GigabitEthernet0/0/18
port link-type access
port default vlan 50
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
port link-type access
port default vlan 50
#
interface NULL0
#
user-interface con 0
user-interface vty 0 4
authentication-mode aaa
user privilege level 15
#
port-group 1
group-member GigabitEthernet0/0/1
group-member GigabitEthernet0/0/2
group-member GigabitEthernet0/0/3
group-member GigabitEthernet0/0/4
group-member GigabitEthernet0/0/5
group-member GigabitEthernet0/0/6
group-member GigabitEthernet0/0/7
group-member GigabitEthernet0/0/8
group-member GigabitEthernet0/0/9
group-member GigabitEthernet0/0/10
group-member GigabitEthernet0/0/11
group-member GigabitEthernet0/0/12
#
port-group 11
group-member GigabitEthernet0/0/13
group-member GigabitEthernet0/0/14
group-member GigabitEthernet0/0/15
group-member GigabitEthernet0/0/16
#
port-group eth5
group-member GigabitEthernet0/0/1
group-member GigabitEthernet0/0/2
group-member GigabitEthernet0/0/3
group-member GigabitEthernet0/0/4
#
port-group eth7
group-member GigabitEthernet0/0/5
group-member GigabitEthernet0/0/6
group-member GigabitEthernet0/0/7
group-member GigabitEthernet0/0/8
#
port-group eth10
group-member GigabitEthernet0/0/9
group-member GigabitEthernet0/0/10
group-member GigabitEthernet0/0/11
group-member GigabitEthernet0/0/12
#
port-group eth11
group-member GigabitEthernet0/0/13
group-member GigabitEthernet0/0/14
group-member GigabitEthernet0/0/15
group-member GigabitEthernet0/0/16
#
return
[ttl-10F-hexin]
回复

使用道具 举报

发表于 2020-12-11 16:30:06 | 显示全部楼层
cfjy8 发表于 2020-12-11 00:18
[ZYTM-10F-hexin]dis cu
#
sysname ZYTM-10F-hexin

不要放在三層交換機中啊!!!將pxe相關的伺服器放在路由器dhcp的同層網絡(switch)中啊!!!

大約根據你的vlan設定,pxe 相關伺服器tcp/ip netmask 應調整至255.255.0.0。

我真的不知道可以再怎麼簡單的說清楚了!!!
回复

使用道具 举报

发表于 2020-12-12 15:20:20 | 显示全部楼层
hkkitlee 发表于 2020-12-11 16:30
不要放在三層交換機中啊!!!將pxe相關的伺服器放在路由器dhcp的同層網絡(switch)中啊!!!

大約根 ...

我们网络没有路由器,纯内网,只是采用了三层交换机,通过vlanif做网关实现跨vlan 跨网段之间通信
回复

使用道具 举报

发表于 2021-2-5 18:34:08 来自手机 | 显示全部楼层
多台机器tinypxe启动不过来只能启动一部分,有没有解决方法
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|捐助支持|无忧启动 ( 闽ICP备05002490号-1 )

闽公网安备 35020302032614号

GMT+8, 2021-3-5 16:02

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表