无忧启动论坛

 找回密码
 注册
搜索
最纯净的「微PE装机优盘」UEPON大师作品系统gho:最纯净好用系统下载站广告联系 QQ:184822951 微信:wuyouceo
楼主: 2012547478659

[求助] 如何解决 httpd error

[复制链接]
 楼主| 发表于 2018-11-9 16:06:35 | 显示全部楼层
江南一根葱 发表于 2018-11-8 20:34
现在有1.0.22了?那我无聊汉化下。。。估计你这个问题一直有的,offline下,右键载入配置,然后保存配置, ...

我猜是tiny pxe server默认httpd的端口号被系统某些应用占用了,但是我不知道在哪里修改tiny pxe server的httpd的端口号的配置

点评

The default port used by the HTTPd daemon is port 80. This may cause conflicts if another web server is running on the network - use this setting to change the port used for HTTP connections. Syntax i  详情 回复 发表于 2018-11-15 15:37
回复

使用道具 举报

 楼主| 发表于 2018-11-9 16:14:32 | 显示全部楼层
2013ghyy 发表于 2018-11-9 10:16
但是我试了,不灵,网上都是这个方法。

服务器系统好解决,直接停用IIS,就不占80了。

谢谢,80端口是被占用,但是IIS的占用不能被解除

点评

有在用IIS?那就直接在IIS新建个虚拟目录给你的启动PE用,tiny pxe server的HTTP就不需要启用了  详情 回复 发表于 2018-11-10 14:55
回复

使用道具 举报

发表于 2018-11-10 14:55:48 | 显示全部楼层
2012547478659 发表于 2018-11-9 16:14
谢谢,80端口是被占用,但是IIS的占用不能被解除

有在用IIS?那就直接在IIS新建个虚拟目录给你的启动PE用,tiny pxe server的HTTP就不需要启用了

点评

刚试了,用IIS可行,只是要配置IIS的MIME类型。  详情 回复 发表于 2018-11-10 19:22
回复

使用道具 举报

发表于 2018-11-10 15:22:27 | 显示全部楼层
还有个方法,直接对tiny PXE SERVER主程序文件pxesrv.exe动手,修改默认的80端口
用Hex Workshop软件打开pxesrv.exe,查找关键字:config.ini 找到如下图的界面,按图修改保存

pxesrv

pxesrv
回复

使用道具 举报

发表于 2018-11-10 16:17:29 | 显示全部楼层
yigeren 发表于 2018-11-10 15:22
还有个方法,直接对tiny PXE SERVER主程序文件pxesrv.exe动手,修改默认的80端口
用Hex Workshop软件打开p ...

改好的主程序发个上来,这个思路不错。
回复

使用道具 举报

 楼主| 发表于 2018-11-10 19:22:02 | 显示全部楼层
yigeren 发表于 2018-11-10 14:55
有在用IIS?那就直接在IIS新建个虚拟目录给你的启动PE用,tiny pxe server的HTTP就不需要启用了

刚试了,用IIS可行,只是要配置IIS的MIME类型。
回复

使用道具 举报

发表于 2018-11-10 20:30:30 | 显示全部楼层
提供一个修改好的最新版本1.0.0.23,界面也都汉化了,HTTP端口修改为83

pxesrv

pxesrv

pxesrv.rar

353.75 KB, 下载次数: 13, 下载积分: 无忧币 -2

1.0.0.23

回复

使用道具 举报

发表于 2018-11-10 21:14:40 | 显示全部楼层
yigeren 发表于 2018-11-10 20:30
提供一个修改好的最新版本1.0.0.23,界面也都汉化了,HTTP端口修改为83

你是优秀的
回复

使用道具 举报

发表于 2018-11-12 22:10:34 | 显示全部楼层
yigeren 发表于 2018-11-10 20:30
提供一个修改好的最新版本1.0.0.23,界面也都汉化了,HTTP端口修改为83

学习了。修改端口有时候多服务很有用
回复

使用道具 举报

发表于 2018-11-15 15:37:28 | 显示全部楼层
2012547478659 发表于 2018-11-9 16:06
我猜是tiny pxe server默认httpd的端口号被系统某些应用占用了,但是我不知道在哪里修改tiny pxe server ...

The default port used by the HTTPd daemon is port 80. This may cause conflicts if another web server is running on the network - use this setting to change the port used for HTTP connections. Syntax is "port=PORT_NUMBER"

例如在 config.ini 中加如下条目即可:
[web]
port=1024
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|捐助支持|无忧启动 ( 闽ICP备05002490号-1 )

闽公网安备 35020302032614号

GMT+8, 2019-12-14 11:59

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表