无忧启动论坛

 找回密码
 注册
搜索
WEPE笔记本电脑手机维修小包 IT发烧友的必备工具最纯净的「微PE装机优盘」UEPON大师作品卡瑞飞系统和装机二合一超级U盘
无忧启动论坛唯一网址:bbs.wuyou.net系统gho:最纯净好用系统下载站广告联系 QQ:184822951 微信:wuyouceo
楼主: slore

[原创] (2019-11-11 更新) Re:WIN10XPE - 从零开始构建的全功能PE

    [复制链接]
发表于 2019-11-12 23:21:38 | 显示全部楼层
把 8GB 的 fbwf 改成 4GB之后,可以正常登入 ADMIN 模式了。但是执行 SwitchUser.bat 来转换两种模式还是有问题。滑鼠点击桌面 SwitchUser.bat 图标之后,桌面一片黑色,必须手动按键盘的 Ctrl+Alt+Delete,运行 explorer.exe 之后才可以显示出 SYSTEM 模式的桌面。而且任务栏的 PENetwork、小小输入法以及输入法指示器都没有了。更加要命的是开始菜单里面,三个外置包的连接图标也不见了(见下图)。老大再看看,有什么解决的办法?

2019-11-12_230024.png

点评

你用DEFAULT,勾选启用Administrator测试看看。 我一直用的19018,反复都没有问题,输入法指示器也正常的。 PECMD.ini有添加外壳守护的更新,你对比下差异。  详情 回复 发表于 2019-11-12 23:27
回复

使用道具 举报

 楼主| 发表于 2019-11-12 23:27:05 | 显示全部楼层
WAIGO 发表于 2019-11-12 23:21
把 8GB 的 fbwf 改成 4GB之后,可以正常登入 ADMIN 模式了。但是执行 SwitchUser.bat 来转换两种模式还是有 ...

你用DEFAULT,勾选启用Administrator测试看看。
我一直用的19018,反复都没有问题,输入法指示器也正常的。


PECMD.ini有添加外壳守护的更新,你对比下差异。

点评

遵嘱用 DEFAULT 选项,并勾选启用 Administrator 测试了多次,首启是 ADMIN 完全没有问题,也可以显示两种输入法。但是由 SYSTEM 转 ADMIN 时,有时还是会失败重启。 看来问题是我没有在 PECMD.ini 添加外壳守护  详情 回复 发表于 2019-11-13 00:11
回复

使用道具 举报

发表于 2019-11-13 00:11:01 | 显示全部楼层
本帖最后由 WAIGO 于 2019-11-13 00:26 编辑
slore 发表于 2019-11-12 23:27
你用DEFAULT,勾选启用Administrator测试看看。
我一直用的19018,反复都没有问题,输入法指示器也正常 ...


遵嘱用 DEFAULT 选项,并勾选启用 Administrator 测试了多次,首启是 ADMIN 完全没有问题,也可以显示两种输入法。但是由 SYSTEM 转 ADMIN 时,有时还是会失败重启。

看来问题是我没有在 PECMD.ini 添加外壳守护的更新。添加后,开始菜单丢失外置软件图标不知是否也能一并得到解决?

恳请告知要在 PECMD.INI 增加哪些代码?非常感谢!


又及:从 PECMD.INI 找到了增加的标签 DaemonShell,但 CALL PreShell 之后就直接跳到 CALL LoadShell,不知这个 DaemonShell 是如何执行的?

点评

PECMD.ini的差分,10.10版本和11.11版本你对比下吧。 主要是SHEL命令的问题。 改成不启用Admin用户,使用SHEL,启用Admin用户,使用DaemonShell子过程,调用监护程序。 > 但是由 SYSTEM 转 ADMIN 时,有时还  详情 回复 发表于 2019-11-13 00:27
回复

使用道具 举报

发表于 2019-11-13 00:18:51 | 显示全部楼层
I couldn't do how to add master opening sound.

2019-11-12_190631.png

点评

Put a batch file to Startup\Before\OpeningSound.bat WinXShell.exe -luacode "app:call('play',[[X:\Windows\media\startup.wav]])" Or WinXShell.exe -luacode "app:call('play',[[X:\PEMaterial\startup.mp3  详情 回复 发表于 2019-11-13 00:32
回复

使用道具 举报

 楼主| 发表于 2019-11-13 00:27:47 | 显示全部楼层
WAIGO 发表于 2019-11-13 00:11
遵嘱用 DEFAULT 选项,并勾选启用 Administrator 测试了多次,首启是 ADMIN 完全没有问题,也可以显示两 ...


PECMD.ini的差分,10.10版本和11.11版本你对比下吧。

主要是SHEL命令的问题。
改成不启用Admin用户,使用SHEL,启用Admin用户,使用DaemonShell子过程,调用监护程序。


但是由 SYSTEM 转 ADMIN 时,有时还是会失败重启。


1分钟内切换,偶尔会提示 缓存管理器出错,蓝屏。
等1分钟后,还是1分半来着就好了,具体原因不清楚。
少东西,还是注册表有问题,细节没时间研究。

点评

PECMD.ini 已添加外壳守护的更新,桌面的 SwitchUser.bat 快捷方式也加上了先执行 DaemonShell,然后再执行 SwitchUser.bat (见划线下面)。但是滑鼠点击桌面快捷方式图标之后,桌面还是变成全黑色,什么图标都没有。  详情 回复 发表于 2019-11-13 18:21
回复

使用道具 举报

 楼主| 发表于 2019-11-13 00:32:01 | 显示全部楼层
本帖最后由 slore 于 2019-11-13 00:33 编辑
gazi06 发表于 2019-11-13 00:18
I couldn't do how to add master opening sound.


Put a batch file to Startup\BeforeShell\OpeningSound.bat
"X:\Program Files\WinXShell.exe" -luacode "app:call('play',[[X:\Windows\media\startup.wav]])"
Or
"X:\Program Files\WinXShell.exe" -luacode "app:call('play',[[X:\PEMaterial\startup.mp3]])"

点评

thank you  发表于 2019-11-13 14:33
回复

使用道具 举报

发表于 2019-11-13 02:58:49 | 显示全部楼层
快速用户切换,需要依靠一个 二次登陆的 系统服务,
回复

使用道具 举报

发表于 2019-11-13 13:34:16 来自手机 | 显示全部楼层
这种情况如何解决?大佬
20191113_124304.jpg
回复

使用道具 举报

发表于 2019-11-13 13:34:40 来自手机 | 显示全部楼层
白图标。。。。。

点评

快捷方式没有指定正确的图标文件。  发表于 2019-11-13 14:15
回复

使用道具 举报

发表于 2019-11-13 14:17:28 | 显示全部楼层
    LINK %StartMenu%\Programs\管理\磁盘管理,%Windir%\System32\diskmgmt.msc,,%Windir%\System32\dmdskres.dll#0
    LINK %StartMenu%\Programs\管理\计算机管理,%Windir%\System32\compmgmt.msc,,%Windir%\System32\mycomput.dll#2
    LINK %StartMenu%\Programs\管理\设备管理,%Windir%\System32\devmgmt.msc,,%Windir%\System32\devmgr.dll#5

点评

大佬,这个磁盘管理的参数还是有问题,图标还是显示白板,。。。  详情 回复 发表于 2019-11-13 16:53
厉害了,我的锅,,,感谢大佬。。。非常感谢大佬,  详情 回复 发表于 2019-11-13 15:34
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|捐助支持|无忧启动 ( 闽ICP备05002490号-1 )

闽公网安备 35020302032614号

GMT+8, 2019-12-7 15:57

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表