助力无忧,捐助本站,加入VIP会员

无忧启动论坛

 找回密码
 注册
搜索
一次装机 终生领工资最纯净的「微PE装机优盘」UEPON大师作品好系统,装机首选好系统

「简单绿色的装机助手」盘云出品

广告位招租广告联系 QQ:184822951 微信:wuyouceo
查看: 332|回复: 7

[求助] deepin livecd如何加回深度商店的完整功能及其余几个困扰

[复制链接]
发表于 2018-4-17 17:33:13 | 显示全部楼层 |阅读模式
一、深度商店问题

这些天一直在瞎折腾deepin live的增强,想把深度商店加回live去

但是通过

sudo apt install deepin-appstore

命令加回深度商店后,显示可以安装的程序,点击install完全没有反应。

在官方源里找了半天,试了很久,也不知道是缺失哪个模块的原因?

当然执行完这个空架子深度商店也不是一点作用没有,最起码终端里下载安装软件的速度一下子飞起。


二、locale问题

这个live很奇葩,即使启动时选择了中文语言,设置的环境也是不完整的,必须终端执行一下

sudo dpkg-reconfigure localepurge

在设置里补充上zh_cn.GBK

否则某些软件安装后只有英文,比如 uget 、 gimp……


三、时间问题

看了很多帖子,反复实验都不理想,重启到win环境,时间落后了  8小时
【暂时有了点思路,还没来得及实践】

请各位大神、高手、朋友、同好不吝赐教,谢谢!

发表于 2018-4-17 17:46:24 来自手机 | 显示全部楼层
本帖最后由 窄口牛 于 2018-4-17 18:56 编辑

没看懂语言设置怎么弄。时间问题建议注册表改win。期待成品分享。
回复 支持 反对

使用道具 举报

发表于 2018-4-17 18:17:52 | 显示全部楼层
本帖最后由 liangyi 于 2018-4-17 18:19 编辑

时间问题
--------来源于深度微信公众号
在安装完双系统后,不少同学都会遇到双系统时间不同步的问题,这是由于Windows和Linux对硬件标准时间的设置不同,Windows默认为当地时间,而linux默认为UTC时间,所以会差8小时。

针对安装双系统出现的时间不同步,我们可做一些配置工作,如下:

1.在deepin系统上打开终端,输入命令。

timedatectlset-local-rtc 1 --adjust-system-clock (把rtc时间解释成本地时间)

sudohwclock -s --localtime (读硬件时间写入系统时间,读硬件时间时解释为本地时间)

sudotimedatectl set-local-rtc true   (将硬件时钟设置为本地时区)
640.png

2.切换回win7,将win7时间修改为正确时间。
640.jpg

3.切换到deepin系统后,终端执行date同步时间。
650.jpg
4.再切回“windows”,双系统时间则一致了。

Ps:切换系统需要时间,可能会产生极小的时差。
回复 支持 反对

使用道具 举报

发表于 2018-4-17 18:57:59 来自手机 | 显示全部楼层
现在的问题是各种非win系统,有的这样(和win一致),有的那样(保持linux方式)。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-4-17 20:35:03 | 显示全部楼层
时间问题 slax 系列一直解决的很好,但是我接触几个 基于ubuntu、debian的则很让人难受。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-4-17 21:38:14 | 显示全部楼层
本帖最后由 hit22 于 2018-4-17 22:13 编辑

虚拟机安装版中发现deepin-deb-installer这个工具还是蛮好用的,刚才放了一个scratch2.0【是深度坛友自己打包的】这个程式自己解决了32位的依赖。

更神奇的是32的linux ghost居然跑起来了。


2018-04-17_213630.png

深度社区里说需要的依赖是:
libgtk2.0-0:i386 libstdc++6:i386 libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386 libqt4-qt3support:i386 libgnome-keyring0:i386 libnss-mdns:i386 libnss3:i386 libasound2:i386 libasound2-plugins:i386

live系统缺少对32位的支持,安装器不能解决依赖。


其他64位的解决的很好。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-4-18 19:08:57 | 显示全部楼层
wintoflash 发表于 2018-4-18 16:18
gtk2-engines-murrine:i386 libqt4-qt3support:i386 libasound2:i386 libasound2-plugins:i386
这几个有点 ...

是的,这几个是scratch2.0这个儿童编程软件需要的。

ghost的这个帖子有说:https://forum.porteus.org/viewtopic.php?t=6680
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-4-18 22:15:01 | 显示全部楼层
本帖最后由 hit22 于 2018-4-18 22:27 编辑
wintoflash 发表于 2018-4-18 16:18
gtk2-engines-murrine:i386 libqt4-qt3support:i386 libasound2:i386 libasound2-plugins:i386
这几个有点 ...


W大,刚才试了半天不行,没头绪了。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|捐助支持本站|无忧启动 ( 闽ICP备05002490号-1

闽公网安备 35020302032614号

GMT+8, 2018-5-27 17:43

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表